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Introduction 

The CSD Conformer Generator provides the ability to both minimise molecular 
conformations and generate diverse conformer subsets based on CSD data. The 
methodology starts from an input 3D molecular structure with all hydrogen 
atoms present, which is optionally minimised in the first step. Subsequently, 
conformations are sampled based on CSD-derived rotamer distributions and ring 
templates. A final diverse set of conformers, clustered according to conformer 
similarity, is returned. Each conformer is locally optimised in torsion space.  
There are three methods for generating conformers with the CSD portfolio; via 
the Mercury interface, the command line utility and the CSD Python API. This 
workshop focuses on generating conformers through the Mercury interface. 

Before beginning this workshop, ensure that you have a registered copy of CSD-
Materials, CSD-Discovery or CSD-Enterprise installed on your computer.  

 

Learning Outcomes 

This tutorial will guide you through the process of generating conformers in 

Mercury. At the end of this workshop, you will be able to: 

• Sketch a structure in Mercury. 

• Generate a set of conformers.  

• Visualize multiple structures at once.  

Note: This handout should take approximately 25 minutes to be completed. 

Pre-required Skills 

Familiarity with the Mercury interface is important; you can access the 
Visualization in Mercury self-guided workshop here or review the basics of 
visualization in Mercury here. Knowledge of sketching a structure in ConQuest is 
expected; a review of sketching in ConQuest is at the end of this document. 

Materials 

There are no additional materials for this workshop. 
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Generating Conformers Workflow 

https://www.ccdc.cam.ac.uk/community/training-and-learning/workshop-materials/csd-core-workshops/
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Example 1. Generating Conformers in Mercury.  
 

In this example, we will go through the steps of setting up a conformer generation 

run in Mercury. The CSD Conformer Generator requires as input 3D structures 

with all hydrogen atoms present. We will be generating conformers for both 

stereoisomers of 2-(4-isobutylphenyl)propionic acid (ibuprofen).  

 

You can either sketch your structure in Mercury, import a .cif file or load one of 

the structures from the CSD by typing the refcode in the Structure Navigator. We 

will first sketch the structure of ibuprofen, but you can use one of the ibuprofen 

refcodes: IBPRAC or IBPRAC05. 

1. Start Mercury by double-clicking on the icon . Click on File > Sketch 

Molecule to bring up the sketcher.  

2. The sketcher interface is the same used in ConQuest. If you need a refresher 

on how to sketch structures in ConQuest, check out the summary at the end 

of this handout. Sketch the structure of ibuprofen shown to the right. 

3. Once you are done sketching the molecule, click Done. Your settings might 

add H atoms by default, making your sketched molecule look a little different. 

We will edit the structure later in Mercury. A pop-up window will appear 

asking for a name for the structure. Provide a name for the structure and click 

OK. 

4. You will now return to the main Mercury window with your sketched 

structure displayed.  

  

CSD Entry IBPRAC  

(S)-2-(4-Isobutylphenyl)propionic acid 

CSD Entry IBPRAC05 

(R)-2-(4-Isobutylphenyl)propionic acid 
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5. We first need to make sure that all bond types in our structure are correct. 

We can do so by using the Edit Structure option. Click Edit > Auto Edit 

Structure. Leave the default options ticked and click Apply. If there are any 

changes made, it will be shown in the pop-up. 

6. 2-(4-Isobutylphenyl)propionic acid has a chiral centre, however we were 

unable to specify chirality when we sketched the structure. We can view the 

configuration that our structure has. Tick the Show Labels for box, select 

Stereocentres with Stereochemistry. The structure shown here is the R 

enantiomer but yours could be different.  

Tip: You can change the label size from the Display menu; Display > Labels > 

Label size. Change the Picking Mode to Move Labels. 

We are now ready to set up the Conformer Generator. The CSD Conformer 

Generator can be accessed through the CSD-Materials and CSD-Discovery 

menus within Mercury.  

7. From the CSD-Materials or CSD-Discovery menu, click on Conformer 

Generation… to open the Conformer Generation window.    
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8. In the Conformer Generation window in the Source molecule section, you can 

specify a CSD entry, an in-house database entry, or another structure as the 

input molecule for conformer generation. The default selected molecule is 

the present molecule in the main display window. Alternatively, you can 

select a file on the disk as the input by selecting From file: option and clicking 

on the Browse button.  

9. The working directory can be selected under Working Directory section of the 

Conformer Generation window. You can stick with the default here or Click 

the Browse button and navigate to the folder you want the results saved to 

A folder will be created in this directory named after the identifier of the input 

molecule used. Both a copy of the input molecule and the generated 

conformers will be written to the output folder.  

10. Conformers may be generated in .mol2 or .sdf format by choosing the 

relevant checkboxes under Output format(s). The default .mol2 format will 

be used in this tutorial. 

11. Tick the Show advanced options to view the defaults. You can change the 

values here if necessary but we will stick with the defaults. 

12. Click the Calculate button to generate conformers.  

13. The calculation should take less than a minute. You can navigate to the folder 

you selected in step 9, the conformers you have generated are placed in 

\path\to\structure\CSD_Conformer_Generator\YYYY_MM_DD_hh_mm_ss\

conformers.mol2.  

Replace \path\to\ with the actual path to the folder selected in step 9. Please 

note that YYYY_MM_DD_hh_mm_ss is the date and time when the calculation 

was run. You will have a different folder name corresponding to your own 

calculation date and time.  
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14. The conformers are also populated in the Structure Navigator as new entries. 

Note that the first conformer generated is now shown in the Mercury 

window. You can scroll through the conformers by clicking on each entry or 

the down arrow on your keyboard. A couple of things to note here are (a.) 

the stereochemistry is conserved in all conformers and (b.) it is not easy to 

see the differences between the conformers if viewing one by one. We will 

load multiple conformers at once and superimpose them. 

15. Tick the Multiple Structures box in the lower right corner of the Mercury 

window. Click on however many conformers you want and the input 

molecule to view them at once. For some users, the structures might be 

superimposed but if they are not, you can use the view options to change 

that. 

16. From the Default view: menu, select Custom. You may need to untick and tick 

again the Multiple Structures box. Now when you click on multiple structures, 

they should be superimposed along the same axis.  

17. You can change the colour of each conformer displayed to make the 

differences more visible. Click on Structures… in the lower right corner to 

bring up the Multiple Structures menu. Change the colour by clicking on by 

Element box and choose a colour. You can also hide some of the entries from 

the display. 

 

 

 

 

 



CONF-001  7 
 
18. The colour of the entries should change in the display window. 

Conclusion 

In this example, we sketched the structure of ibuprofen and generated a set of 

conformers using the Conformer Generator module in Mercury. As mentioned, it 

is possible to generate conformers from structures already in the CSD. You can 

generate conformers for the other enantiomer using either refcode IBPRAC for 

an S enantiomer or IBPRAC05 for an R enantiomer. You can also try changing 

some of the default settings to see if this changes your results. 
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Example 2. Generating Conformers via the CSD Python 
API Script in Mercury. 

1. Load the ibuprofen structure in Mercury or select the entry from the 

Structure Navigator. 

2. From the CSD Python API menu select Analysis > generate_conformers.py 

3. There will be a window showing the progress, the script should take less 

than 30 seconds to be completed. The output folder where the files are 

written is displayed in this window. 

4. Once the script is done running, a Data Analysis window will open with 

the conformers generated and torsion angles in each molecule. Clicking 

on each entry will place the conformer in the Mercury display window. 

You can choose to plot some of the angles or export the parameters. 

5. To export the entries into a .csv, click on File > Export in the Data Analysis 

window. This will open the Export Spreadsheet window where you can 

select items you want saved to the spreadsheet. 

6. If you have experience editing Python scripts and want to view this script, 

it is in path\to\CCDC\ccdc-software\mercury\scripts\Analysis replacing 

path\to\ with your actual install location.  
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Conclusion 
In this example, we have generated conformers for a single molecule in Mercury 
through a script in the CSD Python API menu. The Data Analysis window includes 
the torsion angles in the molecule for each conformer. You can generate plots of 
the torsion angles to view structures that may be outliers. 

Summary 
We have used the conformer generator feature in Mercury to generate 
conformers of ibuprofen. After this workshop you should now be able to: 

• Sketch a structure in Mercury. 

• Generate conformers for a given structure. 

• Use different display options for viewing multiple structures. 

• Analyse results using the Data Analysis window. 

Next Steps 

The CSD Conformer Generator User Guide can be found here or from the 

Documentation and Resources section of our website. There are two other 

methods for generating conformers: via the CSD Python API and the command 

line. If you are interested in exploring those, instructions can be found in the How 

to Generate Ensembles of Conformers using the CSD Conformer Generator (CONF-

002) on this page. 

https://www.ccdc.cam.ac.uk/community/training-and-learning/workshop-

materials/csd-discovery-workshops/  

Feedback 
We hope this workshop improved your understanding of the CSD Conformer 
Generator and you found it useful for your work. As we aim to continuously 
improve our training materials, we would love to hear your feedback. Click on this 
link to a survey (link also available from workshops webpage), it will take less than 
5 minutes to complete. The feedback is anonymous. You will be asked to insert 
the workshop code, which for this self-guided workshop is CONF-001. Thank you!  

https://www.ccdc.cam.ac.uk/media/Conformer-Generator-2024.pdf
https://www.ccdc.cam.ac.uk/community/training-and-learning/workshop-materials/csd-discovery-workshops/
https://www.ccdc.cam.ac.uk/community/training-and-learning/workshop-materials/csd-discovery-workshops/
https://www.ccdc.cam.ac.uk/community/training-and-learning/workshop-materials/csd-discovery-workshops/
https://www.surveymonkey.co.uk/r/CCDC-Online-Workshop
https://www.surveymonkey.co.uk/r/CCDC-Online-Workshop
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Basics of Mercury Visualization 
Mercury is the CCDC’s visualization software to view 3D structures of small 
molecules, generate images, and animations of molecules. 

In the following we will see some of the basics of navigation and visualization in 
Mercury that you will find helpful to support your analysis. 

In the Mercury interface we find: 

• At the top: list of menus from which we can access visualization and 
analysis options, and other CSD components such as CSD-Materials. 

• On the right-hand side: the Structure Navigator, with the database 
loaded (depending on your licence). The Structure Navigator allows you 
to select a refcode to visualize in the main Mercury window. 

• Beneath the main display window: Display options toolbar. You can 
quickly view a packing diagram, display Hydrogen bonding and detailed 
information about the molecule using the More Info option. 

 Using the mouse to enhance visualization: 

• Left mouse button and move – rotate molecules. 
 

• Middle Mouse wheel – move molecules up and down. 
 

• Right mouse button and move up and down – zoom in 
and out of molecules. 
 

• Shift + Left mouse button and move - rotate in the plane 
molecules. 
 

• Ctrl + Left mouse button and move - translate molecules. 
 
 

Right click: 
a) Near a molecule and b) Away from a molecule 
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Review. Draw Window 
 
All drawing takes place in the central white area of the Draw window.  In addition 
to creating 2D chemical structure sketches, the Draw window allows for the 
inclusion of 3D parameters for searching or for filtering. 
 
 

ConQuest sketching conventions 
 

• Left click in the sketcher to insert the selected atom type 
 

• Left click and drag to sketch two bonded atoms 
 

• Use the Edit button to modify properties of or delete atoms, bonds or 
entire substructures 

 

• Right-click on atoms or bonds to modify their properties 
 

• Use the Templates… button to pick from a list of CSD editor devised and 
drawn substructures 

 

• Use the More… button to find less frequently used element types, or 
generic atom type groups (e.g. halogens), or define custom element 
combinations (e.g. C or N or O). 

 
 

 

Define bonds, angles or torsions to be 
monitored during the search, or define 
geometric objects e.g. planes, centroids 
that can be used in computing geometric 
parameters 

Ring template 
selector or 
builder 

List of templates 
for challenging 
substructures 
e.g. adamantane 

Choice of specific or general atom 
types/functional groups 

Choice of 
bond types 


