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Introduction 
ConQuest is the desktop search interface to the Cambridge Structural Database (CSD). All textual, numeric 

and structural data stored within the CSD can be searched using ConQuest. ConQuest provides an 

extensive range of flexible search options, including searching based on compound name, formula, 

elemental composition, and literature references to name a few. The chemical substructure search in 

ConQuest also includes the ability to define chemical constraints such as charge, hybridization state and 

cyclicity and to define 3D geometric parameters that can be used to generate measurement data during 

the search. Geometric objects such as planes, centroids and vectors can also be created and used to 

generate measurement data for advanced analysis; this is the focus of this workshop. ConQuest can export 

data in formats suitable for the Mercury Data Analysis program, for combined data analysis and structure 

visualisation. 

Learning Outcomes 

By the end of this workshop, you will be able to: 

• Create a substructure search in ConQuest. 

• Define centroids, planes and vectors, and distances and angles derived from them. 

• Export measurements from ConQuest. 

• View structures and analyse data in Mercury. 

This workshop will take approximately 25 minutes to be completed if you use the data supplied in the 

Materials section for the Analysing Data in Mercury part of this workshop. If you choose to run the 

ConQuest search, allow an additional 30 minutes for it to complete. The words in Blue Italic in the text are 

linked and reported in the Glossary at the end of this handout. 

Pre-required Skills 

If you have no previous experience with ConQuest, we recommend working through Example 1 in this self-

guided workshop https://www.ccdc.cam.ac.uk/media/Introduction-to-ConQuest.pdf. 

Materials 

A ZIP file containing relevant files can be downloaded here. The folder contains a CSV file, which can be 

used in step 1 of the Analysing Data in Mercury part of this workshop if you do not have time to complete 

the ConQuest search. Alternatively, you can open the CQS file in ConQuest instead of running the search 

in step 44 of Searching in ConQuest. To do so, go to File > Open > Search… in ConQuest. 

  

https://www.ccdc.cam.ac.uk/solutions/software/conquest/
https://www.ccdc.cam.ac.uk/solutions/software/mercury/
https://www.ccdc.cam.ac.uk/media/Introduction-to-ConQuest.pdf
https://downloads.ccdc.cam.ac.uk/tutorials/Virtual_Workshops/conquest_advanced_geom_search_VWS.zip
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Example: Aromatic Interaction in Sandwich Complexes 
Stacking interactions between aromatic ligands coordinated to transition metals have been studied by 

researchers, including Malenov et al.1 who searched for non-covalent interactions between sandwich and 

half-sandwich type complexes with aromatic ligands of different ring sizes. It was reported that 

unsubstituted aromatic rings generally form two types of stacking interaction which are distinguished by 

the degree of horizontal displacement: small (offset < 3.0 Å) and large (offset > 4.5 Å). In this example, we 

will take a subset of the complexes studied, namely sandwich complexes with one unsubstituted 

cyclopentadienyl (Cp) ligand, to demonstrate the general approach to 3D structure searching. 

 

Figure 1. A section of the CSD entry FEROCE04 with a potential parallel displaced stacking interaction 

highlighted. 

Interaction Geometry 

The goal of the ConQuest search is to find instances of the parallel displaced stacking type of aromatic 

interaction, as shown in the Figure 2, below. 

 

Figure 2. Stacking interactions between aromatic ligands in organometallic compounds can be defined 

according to the ellipse 
𝑟2

𝑟max
2 +  

𝑅2

𝑅max
2 ≤ 1 as shown in the diagram. For Cp, rmax = 7.5 Å and Rmax = 4.0 Å. 

 
1 D. P. Malenov, D. Z. Vojislavljević-Vasilev and S. Zarić, Crystallogr. Rev., 31, 2025, 60-95 DOI: 
10.1080/0889311X.2025.2545799 

https://doi.org/10.1080/0889311X.2025.2545799
https://doi.org/10.1080/0889311X.2025.2545799


5 
 

In ConQuest, we cannot measure the horizontal (r) and vertical components (R) directly. Instead, we can 

define centroids (Ω1 and Ω2, Figure 3), and the vector joining them, d. We can then define mean planes 

for each of the C5 rings and calculate the angle between the normal to the plane containing Ω1 and d, θ. 

The angle between the mean planes, φ, should be less than 10° for stacking interactions, as shown in 

Figure 3. 

 

Figure 3. The geometry of aromatic interactions between metal cyclopentadienyl fragments. θ is angle 

between plane normal and vector from centroid Ω1 to centroid Ω2. 

The components, r = |d| sin(θ) and R = |d| cos(θ) can be calculated in Mercury and filters applied to limit 

the data to the boundary of the ellipse in Figure 2. 

A puzzle-type packing motif is often found in sandwich complex crystal structures (see Figure 3). This also 

leads to a parallel arrangement of aromatic ligands, but this arrangement is not an aromatic stacking 

interaction; rather, it is an intermolecular metal-ligand interaction.  

 

Figure 4. A pair of ferrocene molecules from CSD entry FEROCE24. Centroid-to-centroid distance shown. 

To avoid measuring instances of this interaction, further constraints should be applied as shown in Figure 

5. The next section guides you through setting up these geometrical constraints in combination with a 

sandwich complex substructure. 
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Figure 5. Additional geometrical constraints to avoid measuring puzzle-type packing features. Ω1 and Ω2 

are the C5 ring centroids, θ1, θ2, θ3 and θ1 > 90° for true aromatic interaction features. 

Searching in ConQuest 

1. Open ConQuest from the Start menu or by clicking the desktop icon.            Go to the Build Queries 

tab and click on Draw. 
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2. Click the Cp template icon. 

 

3. Click in the sketcher twice to add two Cp rings, on above the other, as shown. 

 

4. Click on the More... drop-down menu at the bottom and select Any Transition Metal. You should see 

TR in the box next to Groups. 

 



8 
 

5. Click in the visualiser area in between the Cp rings to add a transition metal 

 

6. Click on the Bond drop-down menu and select Pi from the bond types. 

 

7. Click on the transition metal 'TR', drag to a carbon atom of the Cp ring and release to add a bond. 

Repeat this process until all 10 metal-carbon bonds have been added. 
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8. Click Edit. 

 

9. Left-click and drag a box around the metallocene substructure using the mouse, then press Ctrl + C 
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10. Press Ctrl + V and reposition the second metallocene above and to the right of the first one. We shall 

refer to the lower left substructures as “1” and the upper right one as “2”. This will be important when 

we create geometric objects involving each substructure. Click in an empty area of the sketcher to 

deselect the molecule. 

 

11. We now need to add hydrogens to the substructure. These only need to be added to the pair of rings 

that we will specify as interacting (using geometric constraints, in the following steps). The other Cp 

ring can have substituents, so we should not add hydrogens to them. Hold down Shift and click on the 

carbon atoms in the upper ring of substructure 1 and the lower ring of substructure 2. They will be 

highlighted in orange. 
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12. From the top menu, click Atoms. 

 

13. Select Hydrogens > Generate > Selected Atoms. 

 

14. Click ADD 3D. 
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15. The Geometric Parameters window will appear. This is where we can define the constraints needed 

to match the conditions discussed in the Interaction Geometry section and where we define the 3D 

parameters that we will be needed for the analysis section later. Click on each atom of the upper Cp 

ring of substructure 1. They will become highlighted green as they are selected. 

 

16. Click Define, next to Centroid. 
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17. Repeat this process to define the centroid for the lower ring of substructure 2. 

 

18. Select the atoms in the upper ring of substructure 1 and click Define next to Plane. This will define 

mean planes involving the carbon atoms of the Cp ring. Do the same for the lower ring of substructure 

2. 
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19. When you have completed these steps you should see CENT1, CENT2, PLN1 and PLN2 in the Defined 

objects panel. Click on CENT1, then CENT2. Click Define next to Vector. 

 

20. Next, click PLN1 and VEC1. Then click Define next to Angle. This will calculate the angle between the 

plane normal and the inter-centroid vector, which we will use later to calculate the components of 

the centroid-centroid distance. 
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21. Click Options. 

 

22. In the RENAME: box, type "theta", then click OK. 

 

23. In the Geometric Parameters window, click on CENT1 and CENT2, then click Define next to Distance. 
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24. We need to tell ConQuest what type of distance to measure. In this example, we are looking for 

intermolecular interactions, therefore, choose the Contact option in the Distance Type window. Then 

click OK. 

 

25. In the Non-bonded Contact Definition window, click Define. 
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26. We need to define a distance range for an intermolecular contact to get reasonable results. From the 

introduction we know the maximum possible distance is 7.5 Å. Therefore, type from 0 to 7.5 in the 

text boxes (ensuring Range is ticked). We will apply the ellipse boundary conditions later on. Click OK. 

 

27. Click OK in the Non-Bonded Contact Definition window. 
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28. Click Options. 

 

29. Rename the parameter "d", then click OK. 

 

30. We next need to restrain the rings to be parallel within a certain tolerance. We can do this by defining 

the angle between their mean planes. Click PLN1 and PLN2, then click Define next to Angle. 
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31. Click Options. 

 

32. In the LIMIT range, type 0 for the lower limit and 10 for the upper limit. Also rename the parameter 

"phi". Click OK. 
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33. We next need to apply some constraints to the angles between the substructures to avoid irrelevant 

interactions (see Figure 5). Recall that (1) and (2) refer to the lower and upper substructures, 

respectively; click, in order, TR(1) CENT1 CENT2. You can see this highlighted green in the next step. 

click Define next to Angle. 

 

34. Click Options. 
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35. Limit the angle range from 90 to 180° and click OK. 

 

36. Following previous two steps, define the angle given by CENT1 CENT2 TR(2) as shown in the image 

below and constrain the angles from 90 to 180°. 
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37. Define the angle given by TR(1) CENT1 TR(2) as shown in the image below and constrain the angles 

from 90 to 180°. 

 

38. Define the angle given by TR(1) CENT2 TR(2) as shown and constrain the angle to be between 90 and 

180°. 
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39. Next, we will define the number of connected atoms to each transition metal. One to nine connected 

atoms can be added as constraints in the search, however since we will have a minimum of 10, we 

will need to gather the number of connected atoms in the search and apply a filter post search. Click 

on TR(1) and click Define next to Atom Properties. 

 

40. Tick the box for Number of connected atoms, then click OK. 
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41. Repeat the preceding two steps to define the number of connected atoms for TR(2). 

 

42. Click Done in the Geometric Parameters window. 

 

43. Click Search. 
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44. Give the search a suitable name, such as cp_sandwich, then in the Filters tab, check 3D coordinates 

determined, R factor <=0.1, Only Non-disordered, No errors, Not polymeric and Only Single crystal 

structures. When you are ready, click Start Search. The search will take about 30 mins to run so we 

recommend proceeding to the Analysing Data in Mercury section on page 29 at this point and using 

the search data supplied here. You can complete this section later. 

 

45. As the search runs, the refcodes of hits will appear in the right-hand side of the window. By default, 

the 2D diagram tab is selected and the first set of measurements are displayed at the top right of the 

diagram. Other tabs can be used to access other information and the 3D structure. 

  

https://downloads.ccdc.cam.ac.uk/tutorials/Virtual_Workshops/conquest_advanced_geom_search_VWS.zip
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46. Click 3D visualiser. 

 

47. The 3D visualiser will appear. The measurements of the defined parameters are shown on the 

structure but to make it easier to visualise, you can scroll through them using the buttons next to 

Param. Objects (centroids, vectors) can be controlled in the same way. 
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48. Click on the Search Overview tab to see a summary of the substructure query and the search settings 

used. Tip: This can be useful if you want to write up results for publications. 

 

49. From the top menus, click File > Export Parameters and Data. 

 

50. In the drop-down menu next to file type, select Spreadsheet. 
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51. Click Save. 

 

52. Using the File Explorer, navigate to where you want to save the file, choose a suitable name and click 

Save. 

 

53. Click File > Save Search As. This will allow you to reopen the session later should you wish to. 
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54. Navigate to a suitable location, choose a file name and click Save. 

 

 

Analysing Data in Mercury 

1. Open Mercury from the Start menu or click on the desktop icon. From the top menus, choose File > 

Open. 
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2. Navigate to the CSV file that was exported from ConQuest in the first part of this example (or use this 

one here). Select the file and click Open. The data will be loaded as a spreadsheet in the Data Analysis 

Module. 

 

3. You will see headers corresponding to the parameters defined in ConQuest, in addition to Identifier, 

Name and Query and Refcode. Identifier and Name are automatically generated from the CSV file by 

the Data Analysis module. Click Tools > Calculator. 

 

  

https://downloads.ccdc.cam.ac.uk/tutorials/Virtual_Workshops/conquest_advanced_geom_search_VWS.zip
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4. We will first calculate the horizontal displacement (corresponding to r in the Interaction Geometry 

section). This can be calculated by multiplying the distance between the centroids (D) by the sine of 

the angle THETA. In the Name panel on the left-hand side of the calculator, click on D, then either type 

the asterisk sign (*) or click on it from the Arithmetic panel on the right-hand side. Next, either type 

Sin() or click on it in the Descriptor operators panel. Place the mouse cursor inside the brackets and 

click on THETA in the Name panel. 

If you used the parameter and search names we recommended, your formula should be: 

'cp_sandwich'.'D' * Sin('cp_sandwich'.'THETA') 

 

5. Add a suitable name in the New descriptor field (we choose “r_h”, with h indicating the horizontal 

component), then click Calculate. The new parameter r_h will appear as a spreadsheet column and 

will also be available in the Name area of the Calculator. 
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6. To calculate the vertical component, R, edit the formula by changing Sin to Cos, type a New descriptor 

(we suggest “r_v” where v indicates the vertical component) and click Calculate. 

 

7. We next need to calculate a variable that can be used to apply the boundary conditions of the ellipse 

described in the Interaction Geometry section. If you used the parameter and search names we 

recommended, the formula should be: 

('cp_sandwich'.'r_h' * 'cp_sandwich'.'r_h') / 56.25 + ('cp_sandwich'.'r_v' * 'cp_sandwich'.'r_v') / 16  

Give the new variable a suitable name such as “ellip_bound” and click Calculate. 
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8. When you are finished, close the Calculator. 

 

9. Click on the column headers TCN1, TCN2 and ellip_bound. They will become shaded in black, which 

indicates they are selected for further use. 
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10. From the top menus, select Selection > Filter. The selected columns will be used to filter out irrelevant 

results. 

 

11. In the resulting Filter window, type an upper limit of 10 for TCN1 and TCN2, and a maximum value of 

1 for the ellip_bound. You may need to scroll to see all of them. Applying these conditions ensures 

that we have conventional metallocene-like structures and that the ellipsoid equation in Figure 2 is 

satisfied. Click Apply. Do not close the Filter window. 
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12. From the top menus, click Selection > Show only selected. This ensures that we will plot only the 

filtered data in the next steps. 

 

13. Deselect the TCN1, TCN2 and ellip_bound columns, and select r_h by clicking on the column header. 

 

14. From the top menus, click Plots > Histogram. 

 



36 
 

15. A histogram will appear. You can move this around and snap it to different panels, or have it as a 

separate tab. We will do the latter. 

 

16. Right-click in the histogram window and select configure from the pop-up menu. 

 

Tip: windows in the Data Analysis module can be 

detached using the windows symbol and snapped 

back into place by dragging and dropping. 
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17. You can customise the histogram display, for example by editing/adding axis titles. When you are 

happy with your customisations click OK. 

 

 

The final histogram should look like shown below. There may be differences depending on your CSD 

version and the number of bins in your histogram (we chose 25). 
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Conclusions 

From the histogram it appears that there might be two possible distributions, one centred at smaller 

horizontal displacements, and one centred at larger horizontal displacement, which appear to overlap 

slightly somewhere around 3-4 Å. This is in keeping with the findings of Malenov et al. who note that small 

horizontal displacements are associated with stronger stacking interactions, but weaker stacking 

interactions at larger displacements are often preferred as they provide areas for additional interactions 

with neighbouring species in crystals, leading to more stable supramolecular structures. 

Exercises 

The data in the original study which included the searches relating to sandwich complexes was published 

in 20182, at which time the percentage of weaker interactions, at 4.5 ≤ r ≤ 7.5 Å, was 73.1% of all contacts 

measured. The number of structures in the CSD has increased substantially since that time.  

Use the sliders in the filters in the Mercury Data Analysis module to evaluate the % of measurements in 

the range 4.5 ≤ r ≤ 7.5 Å in the data you have generated. How does it compare to the 2018 results? 

Hint: name the selections for each particular combination of the sliders and see how many measurements 

are in each set with Manage Selections. 

 

In this exercise, we have used trigonometry to calculate r and R. Can you think of another way of obtaining 

these parameters using distances only? How would you do it in ConQuest? Hint: think about how to obtain 

the normal distance of an object from a plane in ConQuest. 

  

 
2 D. P. Malenov, I. S. Antonijević, M. B. Hall and S. Zarić, CrystEngComm, 20, 2018, 4506-4514, DOI: 
10.1039/C8CE00597D  

1 

2 

https://doi.org/10.1039/C8CE00597D
https://doi.org/10.1039/C8CE00597D
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Summary 
In this workshop we have seen how to create a substructure search in ConQuest to find aromatic 

interactions between metallocene molecules in crystal structures. Calculating centroids, planes and 

vectors automatically with 3D search options was an essential step in generating the data. By using the 

Mercury Data Analysis module, we have been able to confirm the predominance of larger horizontal offset 

aromatic interactions between metallocenes in crystal structures in the CSD.  

For your reference, you can find the ConQuest user manual at this link. 

Next Steps 

If you have enjoyed this workshop, you might like to explore other examples of this type of analysis with 

ConQuest and Mercury. Self-guided workshops CQ-003 and QQ-007 give examples with organic and 

inorganic systems respectively and can be downloaded from the CSD-Core workshops webpage. 

For further examples of filtering and working with selections in Mercury, you can watch this video.  

How to Cite these Tools 

ConQuest: I. J. Bruno, J. C. Cole, P. R. Edgington, M. Kessler, C. F. Macrae, P. McCabe, J. Pearson and R. 

Taylor, Acta Cryst., B58, 389-397, 2002 DOI: 10.1107/S0108768102003324 

Mercury: C. F. Macrae, I. Sovago, S. J. Cottrell, P. T. A. Galek, P. McCabe, E. Pidcock, M. Platings, G. P. Shields, 

J. S. Stevens, M. Towler and P. A. Wood, J. Appl. Cryst., 53, 226-235, 2020 DOI: 

10.1107/S1600576719014092 

Feedback 
We hope this workshop improved your understanding of 3D geometry searching in ConQuest and you 

found it useful for your work. As we aim to continuously improve our training materials, we would love to 

hear your feedback. Follow the link on the workshop homepage and insert the workshop code, which for 

this self-guided workshop is CQ-008. It will only take 5 minutes and your feedback is anonymous. Thank 

you! 

https://www.ccdc.cam.ac.uk/support-and-resources/documentation-and-resources/?category=All%20Categories&product=ConQuest&type=User%20Guide
https://www.ccdc.cam.ac.uk/media/Intermolecular-interaction-search-ConQuest.pdf
https://www.ccdc.cam.ac.uk/media/Exploring-structure-correlations-in-ConQuest.pdf
https://www.ccdc.cam.ac.uk/community/training-and-learning/workshop-materials/csd-core-workshops/
https://youtu.be/QMJzDrUsRYg?si=_2dguCqTmfATC87y
http://dx.doi.org/10.1107/S0108768102003324
https://doi.org/10.1107/S1600576719014092
https://www.surveymonkey.co.uk/r/CCDC-Online-Workshop
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Answers to Exercises 
Using the data supplied in this workshop (derived from CSD version 6.01), the proportion of measurements 

for 4.5 ≤ r ≤ 7.5 Å (with 0 ≤ R ≤ 4.0 Å) is 2644 / 3548 = 74.5%, very similar to the proportion found in the 

2018 study. Your findings may differ depending on your CSD version. 

 

As an alternative to using trigonometry to obtain r and R, the normal distance of a centroid in one ring to 

the mean plane of the other ring – this is R – can be measured directly in ConQuest. The Pythagorean 

theorem can then be applied to calculate r. Note that it is not necessary to define vectors using this 

method, therefore it is simpler to implement and recommended. 

 

Figure 6. Alternative way of calculating r by measuring R directly. 𝑟 = √𝑑2 − 𝑅2. 
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In ConQuest, this would look like a Distance involving CENT1 and PLN2. 
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Glossary  
Aromatic ligands 

In organometallic chemistry, fully π-conjugated rings may be considered aromatic if they have 4n + 2 (n = 

integer) π electrons after accounting their formal charge in the complex. E.g. C4H4
2–, C5H5

–, C6H6, C7H7
+, 

C8H8
2– and so on. 

 

Aromatic stacking interaction 

Aromatics stacking interactions are a subset of aromatic interactions, which are non-covalent forces 

involving aromatic systems such as benzene. Common geometries for aromatic interactions include face-

to-face, edge-to-face and parallel-displaced. Face-to-face and parallel-displaced are subsets of the stacking 

geometry. Additionally, there is a large offset stacking geometry. These three stacking interactions are 

characterised by decreasing normal distances with increasing horizontal displacement. 

 

 

Centroid 

A centroid is the geometric centre of a set of atoms; for aromatic ligands, it is the centre of the ring. 

Sandwich and half-sandwich complexes 

A sandwich complex is an organometallic compound in which a metal atom or ion is positioned between 

two parallel, typically aromatic ligands. Metallocenes, such as ferrocene (CSD refcode family FEROCE), are 

examples of sandwich complexes. In half-sandwich (or piano-stool) complexes, one aromatic ligand is 

replaced by other ligands, for example, in CpFe(CO)2CN (CSD refcode ACODUR) 

Substructure 

A substructure of a structure is a specific smaller part of a structure. It does not need to be a complete 

molecule. For example, the C6 ring of benzene is a substructure of both benzene and phenol but is not a 

complete molecule. 

FEROCE04 ACODUR 
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Review of the ConQuest Interface 

1. Launch ConQuest by clicking the ConQuest Icon  on your desktop or launching it from the Start or 
Applications menu. 

2. The ConQuest main window shows all the search routines you can perform on the left-hand side of 
the window. 

3. The row of tabs across the top of the window will guide you through the steps of the search process.  
4. Some example searches are 

a. Draw – substructure and 3D information searching 
b. Author/Journal – bibliographic searching 
c. Experimental – experimental set up searching 
d. All Text – generic text-based searching 

5. The majority of the searching we will do in these tutorials will be substructure searching, so we will 
focus on the Draw tab here. 
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Review of the Draw Window 

All drawing takes place in the central white area of the Draw window. In addition to creating 2D 
chemical structure sketches, the Draw window allows for the inclusion of 3D parameters for 
searching or for filtering. 
 

ConQuest sketching conventions 

• Left click in the sketcher to insert the selected atom type 
 

• Left click and drag to sketch two bonded atoms 
 

• Use the Edit button to modify properties of or delete atoms, bonds or entire substructures 
 

• Right-click on atoms or bonds to modify their properties 
 

• Use the Templates… button to pick from a list of CSD editor devised and drawn substructures 
 

• Use the More… button to find less frequently used element types, or generic atom type groups 
(e.g. halogens), or define custom element combinations (e.g. C or N or O). 

 

Define bonds, angles or torsions to be 

monitored during the search, or define 

geometric objects e.g. planes, centroids 

that can be used in computing geometric 

parameters 

Ring template 

selector or 

builder 

List of templates 

for challenging 

substructures 

e.g. adamantane 

Choice of specific or general atom 

types/functional groups 
Choice of 

bond types 


